Sesión Invalida

Este fin de semana estuve haciendo pruebas con otras plataformas, y por exigencias de esta tuve que realizar algunos cambios en el php.ini.

Esta mañana he ido a entrar en el administrador de Joomla y me dice Sesión Invalida. He estado repasando todos los cambios que realicé en el php.ini, y restaurando los valores originales en todos ellos pero nada, me sigue diciendo lo de sesión inválida.

Los cambios que realicé son los siguientes:

; error_reporting = E_ALL & ~E_NOTICE
; display_errors = On
; memory_limit = 128M
; session.gc_maxlifetime = 3600
; max_execution_time = 600
; post_max_size = 60M
; upload_max_filesize = 40M
; session.hash_function = 0

En vista de que restaurando los valores originales no se soluciona el problema, he seguido revisando las operaciones que efectué en el server, y una de ellas fue instalar varios paquetes PEAR. He desinstalado directamente php-pear del sistema, pero me sigue dando error.

$ pear list

INSTALLED PACKAGES, CHANNEL PEAR.PHP.NET:
=========================================
PACKAGE                  VERSION  STATE
Archive_Tar              1.3.2    stable
Auth                     1.6.1    stable
Console_Getopt           1.2.3    stable
DB                       1.7.13   stable
HTML_Template_IT         1.2.1    stable
HTTP_Request             1.4.3    stable
MDB2                     2.4.1    stable
MDB2_Driver_mysql        1.4.1    stable
Net_Socket               1.0.9    stable
Net_URL                  1.0.15   stable
OLE                      1.0.0RC1 beta
PEAR                     1.7.1    stable
Spreadsheet_Excel_Writer 0.9.1    beta
Structures_Graph         1.0.2    stable

De momento no se que más hacer. Revisando las instrucciones de configuración que seguí para configurar el nuevo servicio ya está todo desecho.

También he probado a eliminar a restaurar el password del administrador directamente en la base de datos, aunque esto no es ya que si introduzco mal la contraseña me dice que son incorrectos, y si los introduzco de forma correcta lo de Sesión Inválida.

NOTA: Me están fallando las instalaciones de Joomla 1.0.x.
Las que tengo de la rama 1.5.x funcionan sin ningún problema.

Buscaré información referente a sesiones en php a ver si averiguo algo:

SOLUCIÓN

Cuando he ido a realizar una nueva instalación, en este caso de Joomla 1.5.7, en la fase de Comprobación Previa que hace el instalador de Joomla me salen valores en las variables de PHP que no se encuentran en estado recomendado.

Comprobación Previa

Comprobación Previa

Revisando el php.ini me encuentro en la variable session.auto_start un comentario introducido por mí indicando que había sido cambiado por exigencias de otra plataforma, que no fue la que probé este fin de semana y yo andaba revisando, y por eso no me había dado cuenta hasta ahora.

Al cambiar el valor y reiniciar Apache observo que ya puedo entrar sin ningún problema a las instalaciones antiguas. Este valor aunque me dejaba entrar a las instalaciones de Joomla 1.5 a las de Joomla 1.0 me devolvía el mensaje de Sesión Inválida.

Como se ve en la imagen, también register_globals se encuentra en estado recomendado pero sobre esta variable ya estuve haciendo pruebas ayer, y supongo que si estaba en ese estado es por que al finalizar las pruebas se quedó así.

Moraleja: más y mejores comentarios nos pueden ayudar a solucionar imprevistos de esta clase.

Publicado en Joomla 1.0.x, LAMP. Etiquetas: , . 2 Comments »

2 comentarios to “Sesión Invalida”

  1. galax Says:

    he instalado la version 1.5.10 en español y los usuario con los que me debo loguear para administar tmb me dice k session invalida lo volvi a instalar y no escribi ninguna contraseña personal y tmb me aparece lo mismo .. la verdad nose k pasa trata de encriptar md5 la contraseña la cambie y tampoco autentica nose k hacer????

  2. galax Says:

    ya encontre la solucion resulta que cuando uno piensa instalar joolma el pide los valores recomendados para la instalacion resulta que en el php.ini si tienes session.auto_start = 1 es mejor que la cambies a 0 para k funciones algunas , yo cambie este valor alguna ves pq en server no me reconocia las sessiones globales… de todos modos si alguien esta sufriendo por esto ya saben…
    saludos desde
    Colombia..


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: